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Troubleshoot the AksCapacityHeavyUsage error code

This article discusses how to identify and resolve the AksCapacityHeavyUsage error that might occur when you create a Microsoft Azure Kubernetes Service (AKS) cluster.

Symptoms

When you try to create an AKS cluster, you receive the following error message:

Code: AksCapacityHeavyUsage

Message: AKS is experiencing heavy usage in region <Region>. We are working on adding new capacity. In the meantime, please consider creating new AKS clusters in a different region. For a list of all the Azure regions, visit https://aka.ms/aks/regions. For more details on this error, visit https://aka.ms/akscapacityheavyusage.

Cause

You're trying to create a cluster in a region that has limited capacity.

When you create an AKS cluster, Microsoft Azure allocates compute resources to your subscription. You might occasionally experience the AksCapacityHeavyUsage error because of significant growth in demand for Azure Kubernetes Service in specific regions.

Resolution

Solution 1: Select a different region

The easiest and quickest solution is to try to deploy to a different region (for example, NorthEurope instead of WestEurope or UAENorth instead of QatarCentral). To find nearby regions, visit the Azure Geographies page.

This approach might not be feasible if you already have existing resources in the requested region, but it's the preferred solution in a dev/test scenario.

Solution 2: Deploy a cluster that has different settings

The infrastructure that hosts AKS-managed clusters have different allocation reservations. Therefore, AKS might have more capacity for public clusters than it has for private clusters. If you experience the AksCapacityHeavyUsage error when you try to create a private cluster, try to create a public cluster instead (or vice versa).

Solution 3: Use an Azure Enterprise subscription

When capacity is running low, non-Enterprise Agreement (EA) subscriptions are limited first in AKS cluster creation to reserve resources for real production scenarios. If you have an EA subscription, make sure that you use the EA subscription to create the AKS cluster.

Solution 4: Retry the operation

Capacity is often reclaimed when other users stop or delete their AKS clusters. Therefore, the operation might succeed if you retry it later.

More information

Contact us for help

If you have questions, you can ask Azure community support. You can also submit product feedback to Azure feedback community.