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This article discusses how to identify and resolve the "AvailabilityZoneNotSupported" error that occurs when you try to create an Azure Kubernetes Service (AKS) cluster.
Prerequisites
Access to Azure CLI.
Symptoms
An AKS cluster creation fails in specified availability zones, and you receive an "AvailabilityZoneNotSupported" error with the following message:
Preflight validation check for resource(s) for container service <resource-name> in resource group <resource-group-name> failed. Message: The zone(s) '1' for resource '<agentpoolName>' is not supported. The supported zones for location '<location>' are 'A', 'B'
Cause
The issue occurs because the requested SKU has restrictions in some or all zones of your subscription. To verify the restrictions, go to the Verify SKU restrictions section.
Solution
To resolve this issue, follow the Azure region access request process to request access to the specified region or zone.
Verify SKU restrictions
List the SKU details by running one of the following commands:
az vm list-skus -l <location> --size <SKU>az rest --method get \ --url "https://management.azure.com/subscriptions/<subscription>/providers/Microsoft.Compute/skus?%24filter=location+eq+%27<location>%27&api-version=2022-03-01" >> availableSkus.txtNote
Replace
<subscription>,<SKU>, and<location>accordingly.Search for the requested SKU from the command output.
If you see information like the following, it indicates that the requested SKU has restrictions in some or all zones of your subscription:
"restrictions": [ { "type": "Zone", "values": [ "<zone>" ], "restrictionInfo": { "locations": [ "<location>" ], "zones": [ "1", "2", "3" ] }, "reasonCode": "NotAvailableForSubscription" } ]
Contact us for help
If you have questions, you can ask Azure community support. You can also submit product feedback to Azure feedback community.