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erreur KRB_AP_ERR_TKT_EXPIRED dans les tickets Kerberos

Cet article vous aide à résoudre les problèmes d’authentification cohérents susceptibles d’affecter les tickets Kerberos.

Kerberos est un protocole qui utilise des clés secrètes pour fournir une authentification sécurisée pour les applications clientes ou serveurs. Un ticket est émis à un utilisateur pour une authentification réussie. En règle générale, les tickets Kerberos ont une durée de vie d’environ 10 heures et sont renouvelés automatiquement.

Symptômes

Le Centre de distribution de clés (KDC) affiche un message d’erreur KRB_AP_ERR_TKT_EXPIRED indiquant qu’un service a échoué.

Cause

La connexion Kerberos échoue si un utilisateur tente d’utiliser un ticket expiré pour l’authentification. Pour plus d’informations, consultez les conseils de résolution des problèmes liés à l’authentification Kerberos.

Résolution

Pour résoudre cette erreur, procédez comme suit :

  1. Utilisez la KLIST purge commande pour effacer les tickets utilisateur, ou déconnectez-vous et redémarrez l’ordinateur.

  2. Utilisez la KLIST commande avec l’outil SSPIClient pour afficher et gérer les tickets Kerberos et les noms de principaux de service (SPN), comme indiqué dans la commande suivante :

    KLIST GET MSSQLSvc\SQLProd01.contoso.com:1433

Plus d’informations

Problèmes d’authentification cohérents dans SQL Server