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Problème de SPN mal placé explicite dans SQL Server

Cet article vous aide à résoudre un problème d’authentification cohérent SQL Server qui affecte le nom de principal de service (SPN) incorrect explicite.

Symptômes

Si le SPN que vous spécifiez dans le chaîne de connexion existe sur un compte de service qui n’est pas utilisé par Microsoft SQL Server, vous recevez un message d’erreur de contexte SSPI (Security Support Provider Interface).

Si le SPN n’est pas inscrit correctement, vous pouvez recevoir le message d’erreur suivant :

Le principal nom cible est incorrect. Impossible de générer un contexte SSPI.

Si vous essayez de créer un SPN qui existe déjà, vous recevez le message d’erreur suivant :

Dupliquer le SPN trouvé, opération d’abandon !

Cause

Les SPN mal placés explicites peuvent provoquer des problèmes dans l’authentification Kerberos et empêcher les clients de se connecter au service.

Résolution

Si vous rencontrez des noms de service mal placés explicites, vous devrez peut-être créer ou recréer le SPN pour le service. Pour créer ou recréer le SPN à l’aide de la SETSPN commande, procédez comme suit :

  1. Exécutez la SETSPN -L domain\svcacct commande pour répertorier les noms de principal de service sur le compte de service SQL Server.
  2. Exécutez la SETSPN -Q spnName commande pour savoir quel compte de service le SPN est inscrit.
  3. Exécutez la SETSPN -D commande pour supprimer le SPN du service.
  4. Exécutez la SETSPN -A commande pour ajouter le SPN au service.
  5. Déplacez le SPN à l’aide SETSPN -Dde , ou sélectionnez un SPN qui existe déjà dans le compte approprié.

Plus d’informations

Problèmes d’authentification cohérents dans SQL Server