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AvailabilityZoneNotSupported エラー コードのトラブルシューティング

この記事では、Azure Kubernetes Service (AKS) クラスターを作成しようとしたときに発生する "AvailabilityZoneNotSupported" エラーを特定して解決する方法について説明します。

[前提条件]

Azure CLI へのアクセス。

症状

指定した可用性ゾーンで AKS クラスターの作成が失敗し、次のメッセージが表示された "AvailabilityZoneNotSupported" エラーが表示されます。

リソース グループ <resource-group-name のコンテナー サービス >resource-name< のリソースのプリフライト検証チェック>失敗しました。 メッセージ: リソース '<agentpoolName>' のゾーン '1' はサポートされていません。 場所 '<location>' でサポートされているゾーンは'A'、'B' です

原因

この問題は、要求された SKU にサブスクリプションの一部またはすべてのゾーンに制限があるために発生します。 制限を確認するには、「SKU の制限の 確認 」セクションに移動します。

解決策

この問題を解決するには、 Azure リージョンのアクセス要求プロセス に従って、指定したリージョンまたはゾーンへのアクセスを要求します。

SKU の制限を確認する

  1. 次のいずれかのコマンドを実行して、SKU の詳細を一覧表示します。

    az vm list-skus -l <location> --size <SKU> 
    
    az rest --method get \
        --url "https://management.azure.com/subscriptions/<subscription>/providers/Microsoft.Compute/skus?%24filter=location+eq+%27<location>%27&api-version=2022-03-01"  >> availableSkus.txt
    

    それに応じて、 <subscription><SKU>、および <location> を置き換えます。

  2. コマンド出力から要求された SKU を検索します。

  3. 次のような情報が表示される場合は、要求された SKU にサブスクリプションの一部またはすべてのゾーンに制限があることを示します。

    "restrictions": [
                    {
                        "type": "Zone",
                        "values": [
                            "<zone>"
                        ],
                        "restrictionInfo": {
                            "locations": [
                                "<location>"
                            ],
                            "zones": [
                                "1",
                                "2",
                                "3"
                            ]
                        },
                        "reasonCode": "NotAvailableForSubscription"
                    }
                ]
    

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