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OperationNotAllowed または PublicIPCountLimitReached クォータエラーのトラブルシューティング

この記事では、Microsoft Azure Kubernetes Service (AKS) クラスターを作成してデプロイしようとしたときに発生する OperationNotAllowed または PublicIPCountLimitReached クォータ エラーを特定して解決する方法について説明します。

症状

AKS クラスターを作成しようとすると、次のエラー メッセージが表示されます。

Code="操作が許可されていません"

Message="この操作を完了できませんでした。承認された StandardEv3Family のコア数のクォータを超えるためです。"

その他の詳細 - デプロイメント モデル: リソース マネージャー、

場所: uksouth,

現在の制限: 200、

現在の使用状況: 200、

追加の必要: 8。

(最小)新しい制限が必要: 208。

デプロイを成功させるために[詳細]セクションに記載されているパラメーターを指定して、 https://aka.ms/ProdportalCRP/#blade/Microsoft_Azure_Capacity/UsageAndQuota.ReactView/Parameters/<parameter-id> でクォータの引き上げ要求を送信します。 クォータ制限の詳細については、 https://learn.microsoft.com/azure/azure-supportability/per-vm-quota-requestsを参照してください。

または、次のエラー メッセージが表示されます。

標準ロード バランサーの調整に失敗しました。

詳細: outboundReconciler の再試行に失敗しました: カテゴリ: ClientError; SubCode: PublicIPCountLimitReached;

依存関係: Microsoft.Network/PublicIPAddresses;

OrginalError: Code="PublicIPCountLimitReached"(パブリックIP数の制限に達しました)

Message="このリージョンでこのサブスクリプションに対して 1000 を超えるパブリック IP アドレスを作成できません。"Details=[];AKSTeam: ネットワーク、Retriable: false。

原因

SKU のリージョン内のリソースのクォータが使い果たされました。

解決策 1: SKU のクォータの引き上げを要求する

通常、これらのエラー メッセージは、その SKU のクォータを増やすサポート チケットを作成するためのリンクを提供します。 ほとんどの場合、これらの要求は自動的に承認され、クォータの増加は短時間で利用可能になります。

クォータの引き上げを要求するリンクがない場合は、次のように Azure portal で要求を行います。

  1. Azure ポータルでQuotasを検索して選択します。

  2. Microsoft.Compute を選択して、クォータ レコードの一覧を表示します。

  3. Location リストを使用して、リージョンからのレコードのみをフィルター処理します。

  4. クォータが不足している特定のレコードで、レコード行の末尾にある鉛筆アイコンを選択します。

  5. Request クォータの引き上げ ペインで、「新しい上限」フィールドに記入して、「送信」を選択します。

クォータの引き上げ要求が承認されたら、クラスターの作成操作を再試行できます。

解決策 2: 別のリージョンまたは SKU でクラスターを再プロビジョニングする

または、クラスターに十分な容量がある別のリージョンまたは SKU でクラスターを再プロビジョニングすることもできます。

詳細情報

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ご質問がある場合は、 Azure コミュニティサポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。