この記事では、"PublicIPCountLimitReached" エラーを特定して解決する方法について説明します。 このエラーは、Azure Kubernetes Service (AKS) クラスターを作成、更新、またはアップグレードしようとしたときに発生します。 このエラーは、Kubernetes Service タイプのパブリック ロード バランサーのデプロイなど、パブリック IP アドレスの作成をトリガーする他のアクションによっても発生する可能性があります。
症状
パブリック ロード バランサーを持つ Kubernetes サービスのデプロイなど、パブリック IP アドレスの作成をトリガーする AKS クラスターの作成、更新、アップグレード、またはその他の操作が失敗し、"PublicIPCountLimitReached" エラー メッセージが返されます。
原因
このエラーは、サブスクリプションで許可されているパブリック IP アドレスの最大数に達した場合に発生します。 制限は、サブスクリプションの種類によって異なります。 パブリック IP アドレスの制限の詳細については、 この詳細なガイドを参照してください。
解決策
サブスクリプションのパブリック IP 制限またはクォータを増やすには、次の手順に従います。
Azure portal に移動し、操作を実行しているサブスクリプションを選択します。
[ 設定] セクションで、[ 使用量 + クォータ] を選択します。 プロバイダーをネットワークに設定し、必要に応じて AKS クラスターのリージョンでフィルター処理します。
パブリック IP アドレス レコードを見つけます。 同じ行で、[ 新しいサポート要求の作成 ] ボタンを選択します。
[ 新しいサポート要求 ] ページで、必要な新しい制限を指定し、指示に従ってサポート 要求を作成します。
クォータの変更が有効になった後、最初に "PublicIPCountLimitReached" エラーをトリガーした操作を再試行します。
お問い合わせはこちらから
ご質問がある場合は、 Azure コミュニティサポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。