適用対象: Dynamics 365 Field Service、Dataverse
現象
ユーザーが Microsoft Dataverse Web API を使用してデータを入力すると、一部の必須フィールドが見つからないか、作成されたレコードに入力されません。 たとえば、次のスクリーンショットに示すように、作成されたケースでは必須の [ ケース タイトル ] フィールドが空白になります。
影響を受けるケースを開くときに、[ ケース タイトル ] フィールドに値を入力する必要があります。
原因
この問題は、Postman などのサード パーティ製ツールからレコードが作成された場合に発生します。 このようなツールでは、必須フィールドがチェックされません。 代わりに、そのままデータを送信します。
回避策
この問題を回避するには、次の項目を確認してください。
- 必要なフィールドがフローに含まれていることを確認します。
- HTTP 要求によって作成されるエンティティに必須フィールドが存在するかどうかを確認します。