이 문서에서는 AKS(Microsoft Azure Kubernetes Service) 클러스터를 만들 때 발생할 수 있는 오류를 식별하고 해결하는 AksCapacityHeavyUsage 방법을 설명합니다.
증상
AKS 클러스터를 만들려고 하면 다음과 같은 오류 메시지가 표시됩니다.
코드: AksCapacityHeavyUsage
메시지: AKS는 지역 지역에서 <>사용량이 많습니다. 새 용량을 추가하기 위해 노력하고 있습니다. 그 동안 다른 지역에 새 AKS 클러스터를 만드는 것이 좋습니다. 모든 Azure 지역 목록을 보려면 다음을 방문 https://aka.ms/aks/regions하세요. 이 오류에 대한 자세한 내용은 다음을 참조하세요 https://aka.ms/akscapacityheavyusage.
원인
용량이 제한된 지역에서 클러스터를 만들려고 합니다.
AKS 클러스터를 만들 때 Microsoft Azure는 구독에 컴퓨팅 리소스를 할당합니다. 특정 지역에서 Azure Kubernetes Service에 대한 수요가 크게 증가하여 오류가 발생할 수 AksCapacityHeavyUsage 있습니다.
해결 방법
해결 방법 1: 다른 지역 선택
가장 쉽고 빠른 솔루션은 다른 지역에 배포하는 것입니다(예: 카타르 센터 대신 WestEurope 또는 UAENorth 대신 NorthEurope). 인근 지역을 찾으려면 Azure Geographies 페이지를 방문하세요.
요청된 지역에 기존 리소스가 이미 있는 경우 이 방법이 가능하지 않을 수 있지만 개발/테스트 시나리오에서 기본 설정 솔루션입니다.
솔루션 2: 설정이 다른 클러스터 배포
AKS 관리형 클러스터를 호스트하는 인프라에는 다른 할당 예약이 있습니다. 따라서 AKS는 프라이빗 클러스터보다 공용 클러스터에 대한 용량이 더 많을 수 있습니다. 프라이빗 클러스터를 AksCapacityHeavyUsage 만들려고 할 때 오류가 발생하는 경우 공용 클러스터를 대신 만들거나 그 반대의 경우도 마찬가지입니다.
솔루션 3: Azure Enterprise 구독 사용
용량이 부족할 경우 실제 프로덕션 시나리오를 위한 리소스를 예약하기 위해 비기업계약(EA) 구독이 AKS 클러스터 생성 시 먼저 제한됩니다. EA 구독이 있는 경우 EA 구독을 사용하여 AKS 클러스터를 만들어야 합니다.
해결 방법 4: 작업 다시 시도
다른 사용자가 AKS 클러스터를 중지하거나 삭제할 때 용량이 회수되는 경우가 많습니다. 따라서 나중에 다시 시도하면 작업이 성공할 수 있습니다.
추가 정보
사용자 용량을 보장하는 것이 Microsoft의 최우선 과제이며, Azure 서비스의 증가하는 인기를 수용하기 위해 인프라를 확장하기 위해 노력하고 있습니다.
복원력 있는 클라우드 공급망을 제공하기 위한 개선 사항에 대한 자세한 내용은 이 2021년 9월 Azure 블로그 문서를 참조하세요.
도움을 요청하십시오.
질문이 있는 경우 Azure 커뮤니티 지원을 요청할 수 있습니다. Azure 피드백 커뮤니티에 제품 피드백을 제출할 수도 있습니다.