이 문서에서는 AKS(Azure Kubernetes Service) 클러스터를 만들려고 할 때 발생하는 "AvailabilityZoneNotSupported" 오류를 식별하고 해결하는 방법을 설명합니다.
필수 조건
Azure CLI에 대한 액세스.
증상
지정된 가용성 영역에서 AKS 클러스터 만들기가 실패하고 다음 메시지와 함께 "AvailabilityZoneNotSupported" 오류가 표시됩니다.
리소스 그룹 <resource-group-name> 안의 컨테이너 서비스 <resource-name>에 대한 리소스의 사전 유효성 검사에 실패했습니다. 메시지: 리소스 '<agentpoolName'의 존 '1>'은 지원되지 않습니다. 위치 'location<'>에 지원되는 영역은 'A', 'B'입니다.
원인
요청된 SKU에 구독의 일부 또는 모든 영역에 제한이 있기 때문에 문제가 발생합니다. 제한을 확인하려면 SKU 제한 확인 섹션으로 이동합니다.
해결 방법
이 문제를 해결하려면 Azure 지역 액세스 요청 프로세스 에 따라 지정된 지역 또는 영역에 대한 액세스를 요청합니다.
SKU 제한 확인
다음 명령 중 하나를 실행하여 SKU 세부 정보를 나열합니다.
az vm list-skus -l <location> --size <SKU>az rest --method get \ --url "https://management.azure.com/subscriptions/<subscription>/providers/Microsoft.Compute/skus?%24filter=location+eq+%27<location>%27&api-version=2022-03-01" >> availableSkus.txt비고
<subscription>,<SKU>, 및<location>을 그에 따라 대체합니다.명령 출력에서 요청된 SKU를 검색합니다.
다음과 같은 정보가 표시되면 요청된 SKU에 구독의 일부 또는 모든 영역에 제한이 있음을 나타냅니다.
"restrictions": [ { "type": "Zone", "values": [ "<zone>" ], "restrictionInfo": { "locations": [ "<location>" ], "zones": [ "1", "2", "3" ] }, "reasonCode": "NotAvailableForSubscription" } ]
도움을 요청하십시오.
질문이 있는 경우 Azure 커뮤니티 지원을 요청할 수 있습니다. Azure 피드백 커뮤니티에 제품 피드백을 제출할 수도 있습니다.