Udostępnij przez


Rozwiązywanie problemu z błędem PublicIPCountLimitReached

W tym artykule wyjaśniono, jak zidentyfikować i rozwiązać błąd "PublicIPCountLimitReached". Ten błąd występuje podczas próby utworzenia, zaktualizowania lub uaktualnienia klastra usługi Azure Kubernetes Service (AKS). Ten błąd może być również spowodowany przez dowolną inną akcję, która wyzwala tworzenie publicznego adresu IP, na przykład wdrażanie publicznego modułu równoważenia obciążenia typu Kubernetes Service.

Objawy

Tworzenie, aktualizowanie, podnoszenie wersji lub inna operacja klastra AKS, która wyzwala tworzenie publicznego adresu IP, na przykład wdrażanie usługi Kubernetes z publicznym load balancerem, jest niepowodzeniem i zwraca komunikat o błędzie "PublicIPCountLimitReached".

Przyczyna

Ten błąd występuje, jeśli osiągnięto maksymalną liczbę publicznych adresów IP dozwolonych dla subskrypcji. Limit zależy od typu subskrypcji. Aby uzyskać więcej informacji na temat limitów publicznych adresów IP, zapoznaj się z tym szczegółowym przewodnikiem.

Rozwiązanie

Aby zwiększyć limit publicznych adresów IP lub limit przydziału dla subskrypcji, wykonaj następujące kroki:

  1. Przejdź do witryny Azure Portal i wybierz subskrypcje, dla których wykonujesz operację.

  2. W sekcji Ustawienia wybierz pozycję Użycie i limity przydziału. Ustaw Dostawcę na Networking i opcjonalnie filtruj według regionu klastra AKS.

  3. Znajdź rekord Publicznych adresów IP . W tym samym wierszu wybierz przycisk Utwórz nowe żądanie pomocy technicznej .

    Zrzut ekranu przedstawiający sposób tworzenia wniosku o pomoc techniczną w celu zwiększenia limitu przydziału.

  4. Na stronie Nowe żądanie pomocy technicznej określ wymagany nowy limit, a następnie postępuj zgodnie z instrukcjami, aby utworzyć wniosek o pomoc techniczną.

    Zrzut ekranu przedstawiający sposób określania nowego limitu dla publicznych adresów IP.

Po wprowadzeniu zmiany limitu przydziału spróbuj ponownie wykonać operację, która początkowo wyzwoliła błąd "PublicIPCountLimitReached".