Udostępnij przez


Rozwiązywanie problemów z kodem błędu LinkedAuthorizationFailed

W tym artykule omówiono sposób identyfikowania i rozwiązywania błędu występującego LinkedAuthorizationFailed podczas próby utworzenia i wdrożenia klastra usługi Microsoft Azure Kubernetes Service (AKS).

Objawy

Podczas próby utworzenia klastra usługi AKS zostanie wyświetlony następujący komunikat o błędzie:

Uzgadnianie VNet nie powiodło się.

Szczegóły: Ponowna próba usługi VNetReconciler nie powiodła się:

Kategoria: ClientError; Podkodowanie: LinkedAuthorizationFailed;

Zależność: Microsoft.Network/virtualNetworks; BłądOryginalny: Code="LinkedAuthorizationFailed"

Message="Klient „12345678-1234-1234-1234-123456789098” o identyfikatorze obiektu „123456789-1234-1234-1234-1234567890987” ma uprawnienia do wykonywania akcji „Microsoft.Network/virtualNetworks/write” w zakresie „/subscriptions/<subscription-id-guid>/resourceGroups/MC_MyRG_westeurope/providers/Microsoft.Network/virtualNetworks/aks-vnet”, lecz nie ma uprawnień do wykonania akcji „Microsoft.Network/ddosProtectionPlans/join/action” w połączonych zakresach „/subscriptions/<subscription-id-guid>/resourceGroups/ddos-protection-plan-rg/providers/Microsoft.Network/ddosProtectionPlans/upmddosProtectionPlan” lub połączone zakresy są nieprawidłowe."

Zespół AKS: Sieć, Możliwość ponowienia: false.

Przyczyna

Jednostka usługi nie ma uprawnień do korzystania z zasobu wymaganego do utworzenia klastra.

Rozwiązanie

Udziel uprawnień jednostki usługi, aby użyć zasobu wymienionego w komunikacie o błędzie. Przykładowe dane wyjściowe w sekcji "Objawy" zawierają następujące informacje.

Przedmiot Wartość
Jednostka usługi 12345678-1234-1234-1234-123456789098
Zasób /subscriptions/<subscription-id-guid>/resourcegroups/ddos-protection-plan-rg/providers/microsoft.network/ddosprotectionplans/upmddosprotectionplan
Operacja Microsoft.Network/ddosProtectionPlans/join/action

Aby uzyskać więcej informacji na temat udzielania uprawnień jednostce usługi, zobacz Przypisywanie ról platformy Azure przy użyciu witryny Azure Portal.

Więcej informacji

Skontaktuj się z nami, aby uzyskać pomoc

Jeśli masz pytania, możesz zadać pomoc techniczną społeczności platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.