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Este artigo ajuda você a resolver um problema de autenticação consistente do SQL Server que afeta o SPN (Nome da Entidade de Serviço) explícito e extraviado.
Sintomas
Se o SPN especificado na cadeia de conexão existir em uma conta de serviço que não é usada pelo Microsoft SQL Server, você receberá uma mensagem de erro de contexto SSPI.
Se o SPN não estiver registrado corretamente, você poderá receber a seguinte mensagem de erro:
O nome da entidade de destino está incorreto. Não é possível gerar o contexto SSPI.
Se você tentar criar um SPN que já existe, receberá a seguinte mensagem de erro:
SPN duplicado encontrado, operação de anulação!
Motivo
Os SPNs explícitos mal colocados podem causar problemas na autenticação Kerberos e impedir que os clientes se conectem ao serviço.
Resolução
Se você estiver enfrentando SPNs explicitamente extraviados, talvez seja necessário criar ou recriar o SPN para o serviço. Para criar ou recriar o SPN usando o SETSPN comando, siga estas etapas:
- Execute o
SETSPN -L domain\svcacctcomando para listar SPNs na conta de serviço do SQL Server. - Execute o
SETSPN -Q spnNamecomando para saber em qual conta de serviço o SPN está registrado. - Execute o
SETSPN -Dcomando para remover o SPN do serviço. - Execute o
SETSPN -Acomando para adicionar o SPN ao serviço. - Mova o SPN usando
SETSPN -Dou selecione um SPN que já exista na conta correta.