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Este artigo discute como identificar e resolver o erro "AvailabilityZoneNotSupported" que ocorre quando você tenta criar um cluster do AKS (Serviço de Kubernetes do Azure).
Pré-requisitos
Acesso à CLI do Azure.
Sintomas
Uma criação de cluster do AKS falha em zonas de disponibilidade especificadas e você recebe um erro "AvailabilityZoneNotSupported" com a seguinte mensagem:
Falha na verificação de validação para o recurso do serviço de contêiner <resource-name> no grupo de recursos <nome-do-grupo-de-recursos>. Mensagem: A(s) zona(s) '1' para o recurso '<agentpoolName>' não é/são suportada(s). As zonas com suporte para o local '<location>' são 'A', 'B'
Motivo
O problema ocorre porque o SKU solicitado tem restrições em algumas ou em todas as zonas da sua assinatura. Para verificar as restrições, vá para a seção Verificar restrições de SKU .
Solução
Para resolver esse problema, siga o processo de solicitação de acesso da região do Azure para solicitar acesso à região ou zona especificada.
Verificar restrições de SKU
Liste os detalhes da SKU executando um dos seguintes comandos:
az vm list-skus -l <location> --size <SKU>az rest --method get \ --url "https://management.azure.com/subscriptions/<subscription>/providers/Microsoft.Compute/skus?%24filter=location+eq+%27<location>%27&api-version=2022-03-01" >> availableSkus.txtObservação
Substitua
<subscription>,<SKU>e<location>de acordo.Pesquise a SKU solicitada na saída do comando.
Se você vir informações como as seguintes, isso indica que o SKU solicitado tem restrições em algumas ou todas as zonas da sua assinatura:
"restrictions": [ { "type": "Zone", "values": [ "<zone>" ], "restrictionInfo": { "locations": [ "<location>" ], "zones": [ "1", "2", "3" ] }, "reasonCode": "NotAvailableForSubscription" } ]