排查 AksCapacityHeavyUsage 错误代码问题

本文介绍如何识别并解决 AksCapacityHeavyUsage 创建Microsoft Azure Kubernetes 服务(AKS)群集时可能发生的错误。

症状

尝试创建 AKS 群集时,会收到以下错误消息:

代码: AksCapacityHeavyUsage

消息: AKS 在区域 <区域>遇到大量使用情况。 我们正在努力添加新容量。 同时,请考虑在不同的区域中创建新的 AKS 群集。 有关所有 Azure 区域的列表,请访问 https://aka.ms/aks/regions。 有关此错误的更多详细信息,请访问 https://aka.ms/akscapacityheavyusage

原因

尝试在容量有限的区域中创建群集。

创建 AKS 群集时,Microsoft Azure 将计算资源分配给订阅。 由于特定区域中对 Azure Kubernetes 服务的需求显著增长,您可能会偶尔遇到 AksCapacityHeavyUsage 错误。

决议

解决方案 1:选择其他区域

最简单快捷的解决方案是尝试部署到其他区域(例如,NorthEurope 而不是 WestEurope 或 UAENorth 而不是卡塔尔Central)。 若要查找附近的区域,请访问 Azure 地理区域页

如果请求区域中已有现有资源,则此方法可能不可行,但它是开发/测试方案中的首选解决方案。

解决方案 2:部署具有不同设置的群集

承载 AKS 管理群集的基础设施具有不同的资源分配预留。 因此,AKS 对于公共群集的容量可能多于专用群集的容量。 如果尝试创建专用群集时遇到 AksCapacityHeavyUsage 错误,请尝试改为创建公共群集(反之亦然)。

解决方案 3:使用 Azure 企业版订阅

当容量运行不足时,非企业协议(EA)订阅首先在 AKS 群集创建中受到限制,以便为实际生产方案保留资源。 如果有 EA 订阅,请确保使用 EA 订阅创建 AKS 群集。

解决方案 4:重试操作

当其他用户停止或删除其 AKS 群集时,通常会回收容量。 因此,如果稍后重试该操作,操作可能会成功。

详细信息

联系我们寻求帮助

如果有疑问,可以询问 Azure 社区支持。 你还可以将产品反馈提交到 Azure 反馈社区