本文提供了一个解决方案,针对在Microsoft Power Automate桌面版中从云流启动桌面流时发生的无效凭据错误。
适用于: Power Automate
原始 KB 数: 5021155
症状
创建桌面流连接时,会收到以下错误消息:
详细信息:连接失败:[计算机 <计算机 ID>]。 您的凭据存在问题。 检查凭据或使用其他凭据连接到计算机。 关联 ID:<关联 ID>。
运行桌面流时,会收到
WindowsIdentityIncorrect错误代码。 与此错误代码关联的消息可能是“随请求提供的凭据无效”或更具体的内容。{ "error":{ "code": "WindowsIdentityIncorrect", "message": "The credentials provided with the request are invalid." } }
备注
如果出现连接错误,最佳测试是使用远程桌面连接到同一台计算机,并使用创建桌面流时所用的相同凭据。
原因
出现错误消息的原因是连接中的凭据无法在目标计算机上进行身份验证。
创建连接时,Power Automate 会检查以确保凭据有效。 如果凭据未能在目标计算机上通过身份验证,则无法建立连接,并且会收到一条描述问题的错误消息。
如果之前成功创建了连接,但在运行流时遇到错误,则表明用户帐户或计算机中发生了更改。 例如,密码可能已过期。
解决方案
若要查看包含具体详细信息的错误消息,请确保已安装 Power Automate 版本 2.24 或更高版本。 通常,此方法提供足够的信息来解决该问题。 下表显示了一些特定的错误代码和解决方法。
| 错误代码 | 错误消息 | 原因 | 决议 |
|---|---|---|---|
| -1073741477 | 用户已请求未授予登录类型(例如交互式或网络)。 管理员可控制谁可以通过交互方式或通过网络登录。 | 用户帐户在计算机上没有登录权限,或者管理员更改了计算机的策略(检查 用户权限分配 设置)。 | 若要解决此问题,请参阅 在运行桌面流或创建连接时出现的“未授予登录类型”错误。 |
| -1073445812 | 用户的 UPN 不采用预期格式 | 用户使用 DOMAIN\user 登录,但应改用 user@domain.com(或反过来)。 |
尝试使用user@domain.com和DOMAIN\user两种格式登录。 |
| -1073741062 | 智能卡登录是必需的,但未使用 | 不支持连接到需要智能卡登录的计算机。 使用无此要求的机器。 | |
| -1073741715 | 用户名或身份验证信息不正确 | 给定凭据不正确。 由于用户/密码组合或用户名格式不正确,可能会出现此问题。 | 1. 仔细检查你的用户名和密码是否在计算机上工作。 可以通过注销并使用相同凭据重新登录来执行此操作。
2. 如果有效,请通过在桌面流连接帐户的上下文中运行 dsregcmd /status 命令来验证是否使用正确的用户名格式。 请检查输出中的 Executing Account Name值(位于Diagnostic Data部分),并确保它与所使用的用户名匹配。
3. 如果计算机 加入 Microsoft Entra 或在混合环境中,请使用格式 user@domain.com 。 如果计算机仅加入域,请使用格式 DOMAIN\user 。
若要确定正确的用户名格式,请检查计算机的联接状态: a。 运行 dsregcmd /status 命令。 b. 在输出中查找 Device State 部分:- 如果看到 AzureAdJoined : YES,计算机已加入 Microsoft Entra。
- 如果在 AzureAdJoined之后显示NO,但是在DomainJoined之后显示YES,则表示计算机仅加入了域。 |
| -1073741730 | 此域名不可用 | 请确保为计算机加入状态使用正确的用户名格式。 如果您的计算机已加入 Microsoft Entra 或属于混合环境,请使用 user@domain.com 格式。 如果您的计算机仅加入域,请使用格式 DOMAIN\user 。
若要确定正确的用户名格式,请检查计算机的联接状态: 1。 运行 dsregcmd /status 命令。 2. 在输出中查找 Device State 部分: - 如果看到 AzureAdJoined : YES,计算机已加入 Microsoft Entra。
- 如果在 AzureAdJoined之后显示NO,但在DomainJoined之后显示YES,则表示您的机器仅加入域。 |
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| -1073741714 | 用户帐户限制已阻止成功身份验证 | 引用的用户名和身份验证信息有效,但用户帐户限制(如当天时间限制)已阻止身份验证成功。 | 确认没有安全或帐户限制策略阻止此用户成功登录。 |
| -1073741712 | 用户帐户受到限制,因此可能无法从源工作站登录 | 确认没有安全或帐户限制策略阻止此用户成功登录。 |
如果没有与问题相关的更具体的错误,最简单的故障排除方法是使用在连接中输入的确切凭据登录到计算机。 可以通过在本地或通过远程桌面连接登录到计算机来尝试此方法。 您应该收到与 Power Automate 在尝试验证您的凭据时收到的相同错误消息,这将帮助您解决该问题。
可能阻止你登录到目标计算机的其他原因(除了使用不正确的用户名或密码):
- 不支持 PIN。 请确保使用密码而不是 Windows Hello PIN。
- 计算机无法连接到其域或 Microsoft Entra ID(以前称为 Azure Active Directory),因为它没有被正确加入。 若要解决此问题,请参阅 使用 Microsoft Entra 帐户的桌面流无效凭据错误。
- 由于网络问题,计算机无法调用身份验证终结点。 请确保检查网络连接。
下面是用户帐户配置不当的一些常见原因:
- 管理员更改了帐户凭据。
- 域用户帐户未传播到计算机。
- 用户帐户丢失了权限或已禁用。
- 用户帐户密码已过期。