Partager via


Échecs des opérations simultanées du système

S’applique à : Power Platform, Solutions

Cet article fournit une solution de contournement pour un problème qui se produit lorsque vous effectuez plusieurs opérations de solution simultanément dans Microsoft Power Apps. Ces opérations simultanées peuvent entraîner des défaillances, car une seule opération peut être effectuée à la fois. Si vous rencontrez un échec, réessayez l’opération ultérieurement.

Symptômes

Lorsque vous essayez d’effectuer plusieurs opérations de solution simultanément, telles que :

  • Importer une solution
  • Suppression d’une solution
  • Publier les personnalisations
  • Créer un composant de solution
  • Calcul du ruban de fond

Vous recevez un message d’erreur comme celui suivant :

Microsoft.Crm.ObjectModel.CustomizationLockException : Impossible de démarrer l’opération demandée [PublishAll], car il existe un autre [Import] en cours d’exécution pour le moment. Utilisez l’historique des solutions pour plus d’informations. - Échec de l’installation ou de la suppression de la solution en raison de l’installation ou de la suppression d’une autre solution en même temps. Veuillez réessayer plus tard.

Cause

Dataverse autorise une seule opération de solution à la fois. Une demande simultanée pour différentes opérations de solution retourne l’erreur jusqu’à ce que l’opération précédente soit terminée.

Solution de contournement

L’exécution simultanée de plusieurs opérations dans un environnement peut entraîner des conflits. Il est donc préférable d’éviter de le faire.

Pour éviter les conflits,

  • Tenez compte de votre fenêtre de maintenance et planifiez votre déploiement en conséquence. Si vous travaillez dans un environnement de production, vous pouvez modifier votre fenêtre de maintenance en passant à une autre heure.
  • Utilisez la page d’historique des solutions pour vérifier l’état des opérations dans l’environnement.